Cannot OPEN a device in Gurux App

12 posts / 0 new
Last post
raaf1981
Cannot OPEN a device in Gurux App

Hi, I am new here and trying to use LandisGyr optical probe (PLG-1B) to read a data from LandisGyr E350 meter. When I connect my probe, I get dialog asking me about permisson to FT232R USB UART device. When I agree it looks like the probe is connected but when I press OPEN button in the READ option screen I receive some data shown in the trace window 4 times and then an error dialog with information "Failed to receive reply from the device in given time.". Has anyone have an idea what I am doing wrong?

Thanks!

Kurumi
Kurumi's picture

Hi,

I believe that one of your settings is invalid. Try first change "Start protocol" from DLMS to IEC.

BR,
Mikko

________________________________________
Mikko Kurunsaari
Gurux Ltd
http://www.gurux.fi

raaf1981

Thanks for your quick reply.
After changing "start protocol" to IEC I get an error dialog but the message is "Invalid meter type.". I believe that now I need to set the manufacturer properly but I can't see LandisGyr on the list. Is the manufacturer name important for settings or just a template for those settings?

Kurumi
Kurumi's picture

Hi,

You should see Landis+Gyr in the manufacturer list. Let me know if you have any problems.

BR,
Mikko

________________________________________
Mikko Kurunsaari
Gurux Ltd
http://www.gurux.fi

raaf1981

Unfortunately I can't see the LandisGyr on the list (screenshot attached)

Thanks.

Image: 
Kurumi
Kurumi's picture

Hi,

It should be there. I can test this on Friday.

BR,
Mikko

________________________________________
Mikko Kurunsaari
Gurux Ltd
http://www.gurux.fi

raaf1981

Hi,
I have one more question in a meantime:
If I choose the manufacturer from the list do I need to set anything else like physical and logical address or something?

Thanks,
Rafal

Kurumi
Kurumi's picture

Hi Rafal,

Logical and physical are usually set when you select the manufacturer and authentication level. Some manufacturers are using different addresses depending on the communication channel. RS-485 is using a different address than RS-232 or optical head.

You need to try this by yourself.

BR,
Mikko

________________________________________
Mikko Kurunsaari
Gurux Ltd
http://www.gurux.fi

rodrigordantas

Hi Sir,

is It possible to add Circutor manufacturer in the list?

thank you

Rodrigo

Kurumi
Kurumi's picture

Hi Rodrigo,

Please, create a new topic if you have a new question. Create a new topic and I'll answer there what to do.

BR,
Mikko

________________________________________
Mikko Kurunsaari
Gurux Ltd
http://www.gurux.fi

Kurumi
Kurumi's picture

Hi,

You were right and this is now fixed. Get the latest version from GitHub and you can see Landis+Gyr. Also, Italy and India authentication rights are shown better.

Thank you for pointing this out.

BR,
Mikko

________________________________________
Mikko Kurunsaari
Gurux Ltd
http://www.gurux.fi

raaf1981

Thank you, I can see Landis+Gyr on the list. Unfortunately when I press the Open button it says "Invalid meter type" (IEC start protocol). On the start protocol DLMS I got "Failed to receive reply from the device in given time". I have an application from Google Store ("ZRobo") and it gives me the readings so I am sure that my header is working properly but the only setting in ZRobo is a baud rate (set to 300) and nothing else that's why I suppose there is a settings problem and I have no idea how to solve it. Do you have any clue?

Thanks,
Rafal